Sirvoy - Email Delivery Issue – Incident details

All systems operational

Email Delivery Issue

Resolved
Partial outage 20 %
Started 26 days agoLasted 2 days

Affected

Messaging services

Partial outage from 5:55 PM to 2:00 AM

Emails

Partial outage from 5:55 PM to 2:00 AM

Updates
  • Resolved
    Resolved

    The issue that caused delays in email delivery to Microsoft domains (live.com, hotmail.com, outlook.com, msn.com) has been resolved.
    Most affected emails have now been delivered. However, some messages may have failed due to timeouts. Please verify delivery and resend if necessary.
    We apologize for any inconvenience caused.

  • Identified
    Identified

    At the moment, some customers may experience delays in email delivery to Microsoft email domains, including live.com, hotmail.com, and outlook.com.

    Emails are temporarily delayed but are still being retried automatically. We are closely monitoring the situation together with our email provider.

    We apologize for any inconvenience and will share further updates as soon as more information becomes available.